PyPI Stats

Search

All packages
Top packages

Track packages

lightning


PyPI page
Home page
Author: Lightning AI et al.
License: Apache-2.0
Summary: The Deep Learning framework to train, deploy, and ship AI products Lightning fast.
Latest version: 2.3.0
Required dependencies: deepspeed | fsspec | lightning-utilities | numpy | packaging | pytorch-lightning | pyyaml | torch | torchmetrics | tqdm | typing-extensions
Optional dependencies: aiohttp | arrow | backoff | beautifulsoup4 | bitsandbytes | click | cloudpickle | coverage | croniter | dateutils | deepdiff | docker | fastapi | fsspec | httpx | hydra-core | inquirer | ipython | jinja2 | jsonargparse | lightning-api-access | lightning-cloud | lightning-fabric | lightning-utilities | litdata | matplotlib | omegaconf | onnx | onnxruntime | packaging | pandas | playwright | psutil | pydantic | pympler | pytest | pytest-asyncio | pytest-cov | pytest-doctestplus | pytest-random-order | pytest-rerunfailures | pytest-timeout | pytest-xdist | python-multipart | pytorch-lightning | pyyaml | redis | requests | requests-mock | rich | s3fs | scikit-learn | setuptools | starlette | tensorboard | tensorboardx | torchmetrics | torchvision | traitlets | trio | typing-extensions | urllib3 | uvicorn | websocket-client | websockets

Downloads last day: 15,375
Downloads last week: 97,632
Downloads last month: 844,622