PyPI Stats

Search

All packages
Top packages

Track packages

magicgui


PyPI page
Home page
Author: Talley Lambert
License: MIT license
Summary: build GUIs from functions, using magic
Latest version: 0.6.1
Required dependencies: docstring-parser | pandas | psygnal | pyside2 | qtpy | superqt | typing-extensions
Optional dependencies: black | flake8 | flake8-docstrings | flake8-typing-imports | ipython | ipywidgets | isort | matplotlib | mypy | numpy | pillow | pre-commit | pydocstyle | pyqt5 | pyqt6 | pyside6 | pytest | pytest-cov | pytest-mypy-testing | pytest-qt | toolz | tox | tox-conda | tqdm

Downloads last day: 1,132
Downloads last week: 6,143
Downloads last month: 25,628